PDA

View Full Version : Advice


paultracy3
02-19-2012, 05:52 AM
Whats up guys . I sold my 99 newell and i am about to pic up a 02 4 slide . Went to take it for a test drive the other day and we had the gen running . It was at 210 , i thought that was on the hot side for a 65* day . We turned on the dash ac on low fan speed and the gen temp went to 230* in about 30 sec . As we turned up the dash ac the hotter the gen temp got fast , on hi fan the temp went to 360* the digital gauge then started to flash hi-hi-hi but the gen never shut down . Heres the weird thing from 260* i turned the ac off and the temp droped 60* in 1min , i then turned the ac on full and the temp would go to 260 faster than you could count it out . I know for a fact that you cannot heat or cool water that fast even under a fire . We got back to the dealer and showed him what was going on and could replicate it in the lot . He said he would look into it . And have his mechanic check it out . Red flag or not ???

encantotom
02-19-2012, 06:30 AM
hi paul,

i am trying to think how the dash ac (i assume with the coach engine running) would have any impact on the generator temp. the temp sender on my 02 genny is right near the thermostat and from there it goes i believe straight to the gauge.

you are for sure right that the temp couldnt go up and down that fast.

if it has the same genny engine as mine, it is a kubota 2003turbo. i looked in the manual and there doesnt appear to be a high temp shutoff switch in it.

the digital gauge for my genny temp is over the drivers head. so it is either the sender, the gauge or a connection.

btw, my genny temp gauge reads lower than actual temp all the time. i will be figuring out what is wrong with mine too.

tom

paultracy3
02-19-2012, 06:53 AM
This one is over the driver head too , a red digital type gauge , the ac condenser and fan is in the blower compartment for the gen rediator infront of the front wheel

GORDON HUMMEL
02-19-2012, 01:26 PM
I'll bet on a bad ground.

I had a situation when I would push in the cigar lighter in & would loose 15 psi of oil pressure. At the same time the temp gauge would go up +/- 15 deg?

encantotom
02-19-2012, 03:24 PM
paul, i know you are very good at this stuff too. for me i wouldnt let that get in the way of a good deal on the 02. it might take some time, but i would either have the dealer fix it or estimate what it would take to fix and take it off the deal price.

tom

Wally Arntzen
02-19-2012, 04:06 PM
If you have a digital temp reader shoot it at the radiator and see what the temp really is when your doing the tests with the AC system. Check it out when the the generator is just running with no load as well. You may just have a defective read out guage.

larryweikart
02-19-2012, 11:50 PM
Paul: I have had the same situation with my oil pressure gauge and engine heat gauge for years. Whenever I used my radio, dash air, windshield wipers, headlights, etc,etc, my oil pressure would go down and the engine temp would go up. It is probably a ground problem. Newell sometimes puts too many systems on the same ground. We've never really been able to completely cure the problem but are aware of what causes it.

encantotom
02-20-2012, 12:17 AM
paul, what i assumed that you meant is that the genny temp gauge is the one acting up, right?

in my 90 i ran quite a few extra grounds to the instrument panel. the grounds were daisy chained to the gauges. it helped some but not entirely.

tom

tuga
02-20-2012, 03:16 AM
Paul,

I had a generator overheating problem. With 98 degree outside temps the gen would run about 210-225 degrees. The dash AC evaporator coil is located in my generator blower bay. It dumps hot air into that compartment; so if the dash AC is running the air that is picked up by the gen blower is considerable hotter than ambient.

Here's some of the things I did trying to fix it.

1. Removed radiator and had it cleaned and rodded by a radiator shop.
2. Changed the water pump, thermostat, VDO gauge on the dash, and blower belt.
3. Checked the flow of air coming from the gen blower for obstructions.
4. Discovered air escaping from the generator door cover while the gen was running (the gen door that I mention has Newell written on it). No air is supposed to escape from this door while the gen is running.
5. Installed 2x6 piece of wood to re-direct the air flow thru the generator compartment

None of the above things have fixed it!

paultracy3
03-01-2012, 02:10 AM
I bought the new coach , seems that the temp sensor had been changed out at some point and did not jive with the current guage . Dealer is switching it out to a dakota digital guage and sender

encantotom
03-01-2012, 02:42 AM
that makes perfect sense. that is what i think happened to mine as well. i see there is a new sender and i am sure it is an old gauge.

thanks for the update

tom

express1
10-25-2012, 04:11 AM
Not that this applies to anything other than Cannon's 16kw genset. But anyway Newell did not have and did not know what the temp-rate was.
Anyway we got a new one today. Kubota Part #19434-73014. 160 degree. His genny has shut down due to high temp twice since leaving Newell. We will replace and try that... Sometimes it will run for 6-8 hrs no problem....
Still stuck in Vegas...lol!