Using Garmin for backup camera monitor/speedometer - Luxury Coach Lifestyles
Reply
 
Thread Tools Display Modes
 
Old 10-04-2013, 09:30 AM   #1
sherikoska
New Member
 
Join Date: Aug 2013
Location: Watertown, SD
Posts: 4
Default Using Garmin for backup camera monitor/speedometer

Our Sony camera monitor (1994 SSM 721 AMR) stopped working after having a shopTRY (and fail) to fix the passenger wiper motor, so I'm guessing something is just loose, but we are probably just going to replace it. Our speedometer also only works when it feels like it so I'm assuming it's a grounding issue. We are also looking at the Garmin gps systems, and I'm wondering if anyone has put one in and used it for a monitor on the backup camera as well as a speedometer? This seems like it would be the easiest fix for everything if it's feasible. We are not at all techy peeps! B-)
__________________

sherikoska is offline   Reply With Quote
Old 10-04-2013, 03:46 PM   #2
rellick
Senior Member
 
rellick's Avatar
 
Join Date: Dec 2012
Location: Sexsmith Alberta Canada
Posts: 594
Default

Welcome to LCL sherikoska! I understand your frustration, it does take some time to get used to how everything works on a Newell , it can be a real learning curve!! I would try and have your wiring issue fixed, if it is just some loose wires it may cause more "gremlins" later on down the road. It sounds like someone my have been up under the dash and bumped some wires. Grounds are a good thing to check also, they can be troublesome. With your wiper motor it could be your switch, fuse, loose wire or ground. If the shop you had look at it doesnt seem compitent it would be a good idea to get someone that knows how to troubleshoot wiring check it over.
Upgrading your back-up cam to a gps system would be nice rather than a replacement camara but I would still look in to your wiring issue, sometimes its as easy as a loose connecter or ground, just a matter of finding it
__________________

__________________
Keith, Krista and Family
77 38' Newell Coach Repowered from Smokin' V555TA To 325hp 8.3 inline 6 cummins, Allison 3000 series trans
87 40' Newell Coach 475hp 8V92 DD(sold)
22' 350hp Jet Riverboat
79 Ford F250 4x4
Many others to list
rellick is offline   Reply With Quote
Old 10-04-2013, 04:34 PM   #3
77newell
Senior Member
 
Join Date: May 2008
Location: Just North of Detroit, a surprizingly great city
Posts: 380
Default

sherikoska:I'm guessing your coach is a 1994 based upon that number appearing as part of the Sony number. Yeah, I would concur with your assessment that you monitor problem is a "since-U" problem. Since you worked on that this stopped working. Finding your way to the back of the monitor and tightening the connections would be my first gambit. The other approach there would be to assure that both power and ground are available at the monitor, loss of either will kill it's operation.

Regarding your speedo, my 93 has electronic internals and can fail internally in ways that duplicate your symptoms, but again if it started doing this when the wipers were worked on then either the wires on the back have become loose or the ground is insecure. My speedo gets a pulse signal from the transmission computer and a weak contact could cause missed pulses. As far as I could find so far the signal wire runs direct from the computer to the speedo so if connection is a problem it is likely only at the ends. BTW a replacement speedo was less than 200 dollars and only a little easy programming was needed. So if this problem predated the wiper work it is probably the speedo, if coincidental to that work it is probably the connections on the back of the speedo.

Regarding the wipers, I haven't had to get into them since they are still going flippy floppy and I hope they continue that way for a long time.
__________________
Jon and Alie Kabbe
Started with 77 Coach
Now have 39' 93 coach
2007 civic toad
77newell is offline   Reply With Quote
Old 10-04-2013, 05:07 PM   #4
folivier
Senior Member
 
folivier's Avatar
 
Join Date: Sep 2008
Location: Thibodaux, LA
Posts: 1,221
Default

I like a separate rear view camera since I leave it on to keep an eye on my toad.
BTW my Sony camera is giving me problems also so I intend to replace it this winter, probably with one from Rear View Safety and use this monitor:
Ford backup camera systems
That will put it more in line with my scanning while I drive. Now the monitor is at the bottom of the console near the floor. Not easy to see.
__________________
Forest & Cindy Olivier
1998 Newell 45' 2 slide #486
2004 Chevy Silverado Z71
2013 RZR 570LE

"You don't have a soul. You are a soul, you have a body." C.S.Lewis


http://www.LuxuryCoachLifestyle.com/...php?albumid=14
folivier is offline   Reply With Quote
Old 10-04-2013, 08:33 PM   #5
sherikoska
New Member
 
Join Date: Aug 2013
Location: Watertown, SD
Posts: 4
Default

The coach is a 95. The monitor was fine when we test drove it but went gray after having the dealer work on other issues. (In their defense, they work on semis so I'm sure much of this Newell stuff is foreign to them. Tbey were working on the passenger wiper and AC units). We checked all wires to the monitor and they were fine, the screen was lit up but no pic, and then wben I put the splice clip back together I got zapped a little and now the screen is black but flashes when turned on. We have checked many wires and haven't found any loose or bad ones (yet!) Watching the toad separately probably is a good idea though. BTW, we are looking for a newer Jeep Wrangler for a toad if anyone is selling. Currently using Avalanche but it's overkill and not as much fun. As for the wipers, driver's side works fine. Thanks to everyone for all help and suggestions! I think I've read almost every post on this site and feel like I've gone back to school. Hopefully I'll graduate soon! How complicated is it to just take out the entire dash? I'd love to see the hands on the Newell shop guys, as I have a helluva time getting mine up in there! Lol! Working on this coach makes me crave Bud Light B-)
sherikoska is offline   Reply With Quote
Old 10-04-2013, 09:25 PM   #6
folivier
Senior Member
 
folivier's Avatar
 
Join Date: Sep 2008
Location: Thibodaux, LA
Posts: 1,221
Default

One suggestion, your monitor may have 2 inputs. My Sony went out and I was able to move the camera cable to the other input on back of monitor and it works. I had to select the other I put with a button on monitor.
__________________
Forest & Cindy Olivier
1998 Newell 45' 2 slide #486
2004 Chevy Silverado Z71
2013 RZR 570LE

"You don't have a soul. You are a soul, you have a body." C.S.Lewis


http://www.LuxuryCoachLifestyle.com/...php?albumid=14
folivier is offline   Reply With Quote
Old 10-04-2013, 11:44 PM   #7
sherikoska
New Member
 
Join Date: Aug 2013
Location: Watertown, SD
Posts: 4
Default

Thanks Forest! The monitor does have two inputs and I tried that but didn't help. I think in the long run it might be best to remove the dash and check EVERYTHING. Who knows what we may muck up in the process but it's one way to get to know it.
__________________
Randy Hartley and Sheri 1995 42.5' Newell #399
2005 JEEP Rubicon, 2012 Chevy Avalanche
1974 Corvette Stingray, 2003 HD Ultra Classic
1949 Custom Panshovel, 2009 "Obamacar"
1955 Plymouth Plaza (work in progress!)
sherikoska is offline   Reply With Quote
Old 10-05-2013, 03:09 AM   #8
ccjohnson
Senior Member
 
ccjohnson's Avatar
 
Join Date: Jan 2012
Location: Southwest NM
Posts: 346
Default

I have gotten in the habit of taking a lot of digital pictures when working on anything with wires. Also label each wire if possible when disconnecting. Between these 2 things I get stuff back together the right way a lot easier. Also a pic e-mailed to Newell tech support can speed up your helpful answers from them.
__________________

__________________
Clint C. Johnson / Fran Balm
Coach 289 '92 42'6" 8V92 Hybrid
Several Toads:
XL-7
F-350 4X4 Crewcab
F-250 4X4 Crewcab
ccjohnson is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Drip Rail Removal & Reseal MiracleJ Exterior Works 2 04-29-2013 04:09 PM
air pressure available from onboard air system? Gary&Terry General Luxury Coach Discussion 2 01-29-2013 05:07 AM
'87 DD 8V92 readings, sights and sounds KimnKim Major Mechanicals 5 10-03-2008 01:49 AM
Do You Have Dimpled Light Bulbs? fulltiming Interior Works 0 10-15-2007 02:06 PM

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Newell Coach Corporation or any of its affiliates. This is an independent, unofficial site.



All times are GMT. The time now is 11:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.