View Full Version : Red Light Polarity Issue at British Columbia Camp Ground

08-22-2010, 02:57 PM
I plugged into a CG power pedestal in Dawson Creek, British Columbia and the red polarity light lit. This had never happened to me before so I was caught a little off guard. I went inside the coach and looked at the panel above the driver's seat and the red polarity light was also lit. About that time I saw the voltage drop from 120 to 80 to 40 and then to -0-.

Long story short the polarity was reversed at the CG power outlet. The CG manager and I turned off the circuit breaker which tripped and we switched the black and white wires in the power pedestal. I plugged back into CG power and everthing worked fine - except my inverter - it was toast.


Ron, an electrician at Newell, said that a relay in the inverter was probably sacrificed. I just sent it off to be repaired. Hope that the relay is all that was damaged.

08-22-2010, 04:35 PM
Is the campground going to pay for your inverter?

08-22-2010, 05:37 PM
I doubt it; I am going to submit the bill to repair the inverter, but I doubt seriously whether they will pay. I don't have my receipt for the site rent, so I really can't prove that I was there! All I remember is that I was in site # 7.

Lesson to be learned here is: KEEP YOUR RECEIPTS and watch for that red polarity light.

08-22-2010, 06:13 PM
I have only run across that issue one time. I was using a power conditioner which saved the coach and took itself out. Obviously that is one advantage of having additional power conditioning/protection.

08-22-2010, 10:50 PM
I have only run across that issue one time. I was using a power conditioner which saved the coach and took itself out. Obviously that is one advantage of having additional power conditioning/protection.


What kind of power conditioner do you use presently?

I think that I may be in the market for one.

How many other of you guys use a power conditioner, if I may ask?

08-23-2010, 01:52 AM
Tuga, at the time, I was using a Hughes Autoformer, which has reverse polarity protection by taking out its input diode pack. I regret to say that currently I am not running surge/polarity protection. I do take the precaution of leaving the manual transfer switch in the off position when I plug in. Then I check the polarity light before I change the manual transfer switch to Shoreline. Since the newer Newell all have automatic switchover, this approach wouldn't work for them. I have just been lucky on the surges so far. I would certainly consider the Progressive Industries model.

Newell includes surge protection on all their new coaches. You might check with them to gain the wisdom of their experience.

08-23-2010, 06:18 AM
i have posted in other areas about this as well. i have the hard wired in progressive industries power monitoring system. it is quite awesome.


08-23-2010, 12:36 PM
I emailed Newell this morning to ask what brand they recommend. I'll post it when I hear from them.

Some Prevost friends of mine use the Progressive model that plugs into the CG power outlet, but they have had trouble with this unit. It would give false readings, not connect, etc. Progressive would always replace defective unit with a new one and over time they would find one that would work. Hopefully I can find a brand that gets it right the first time.


Has anyone used this brand?

08-23-2010, 01:18 PM
mine is hardwired in and has been flawless


08-23-2010, 02:07 PM
I met a guy in at Rancho Jurupa Regional Park that uses PowerMaster (http://rvperformanceproducts.com/voltagecontrol.htm). They are external, and plug into the CG pedestal. They will protect against surges, they will boost low voltage up to 12%. I"m not sure about reverse polarity issues though. I'll have to check. I think I more interested, now, in Tom's setup. Tom, what was your source other than direct from Progressive Industries?

08-27-2010, 09:30 PM
I spoke to Tom and Richard today and they have both helped out with my little problem. Here's what I have decided to do based on their advice:

1. Since the inverter repair shop has checked the unit out and it is working properly, I am going to mount it back in the Newell when I get it home on Sept 5th.

2. After I get everything connected, I am going to fully charge ALL the batteries using the inverter/converter. In order for a battery to be properly load tested it must first be charged fully.

3. I am going to load test all of the batteries again, but this time not at Batteries Plus but at a local truck repair shop. They will be able to better load test the batteries. Based on the results of this test I am going to "equalize" the batteries using the Heart Freedom 2500 inverter/converter as per their instructions. Before equalizing, I am going to check with Newell to see if there are any 12v appliances that need to be disconnected first.

4. After the equalizing is done I will load test them again. At this point I should be able to make a decision whether or not to buy a new set of batteries.

Thanks again to Richard and Tom.

09-08-2010, 05:32 PM
Well I got the inverter back from the repair shop; they said nothing was wrong with it. It is inverting correctly. So I put it back in the coach and voila! It works! It runs the coffee pot, refrigerator, and TV etc. The battery charger works also.

So what we have here is: an inverter that was not inverting - Newell tried to re-set it by disconnecting the power to it for 20 minutes (that didn't work) then it was removed from the coach and tested by a qualified repair shop - nothing was wrong with it - and now it inverts!

I'm confused!

If anyone has this problem I would suggest:

1. Disconnect the positive and negative cables at the inverter for about 24 hours
2. Charge up all of your batteries with a separate battery charge to a FULL charge
3. Reconnect the positive and negative cables at the inverter (connect the negative then connect the positive).
4. Try to invert again

09-08-2010, 06:39 PM

As a matter of fact, I have had a very similar experience. I purchased my Newell in Phoenix and stopped at the factory on the way east. The inverter never inverted a lick from the day I got it. That was not a deal breaker and I did not worry much about it at the time. I did mention it to the techs at the factory and they gave me the disconnect the batteries and wait as a possible action to get it going. I did better than that, I had the coach batteries replaced while I was there. So, no batteries for hours and then new fully charged batteries. Well, the inverter still refused to make any AC while continuing to charge just fine. I pulled it out and drove to a great inverter repair service just north of Nashville in a little city called White House. In nothing flat, and just as I was settling down for a long wait, the guy announced there is nothing wrong with my inverter. This I have got to see so he shows me this huge bank of glowing red resistor heaters and a wattage output of just over 2200 watts. I stand there in amazement. He asks what remote I use to control the inverter and I reply the Link 2000. Ah, he says, that's your problem! So I haul her home and do a temporary install with the Link 2000 unplugged and drop the AC and it inverts like crazy running everything I turn on. I then plug in the Link 2000 and it won't invert anymore. My Link 2000 I traced out and it is fed from the chassis batteries. So I disconnected it completely, reconnected and set all the parameters correctly for my situation - 6 house 8D batteries and crossed my fingers. Success - works now like it is supposed to. So my additional suggestion would be to make sure all power is removed from the inverter controller allowing it a chance to reset and make sure all the parameters are correct. And as a simpler test, just unplug the remote and select local control at the inverter and see if that gets it going.

09-08-2010, 10:07 PM

When you say unplug the Link 2000 do you mean unplug the phone cord connection? Because I think that the other wire is hard wired to the Link 2000 display board.

The only difference in my situation compared to yours is that I didn't do anything to my Link 2000 after I re-installed my inverter. It just came on.

I suppose somehow the Link 2000 is the culprit. I guess by disconnecting the inverter and then re-connecting it - that somehow reset the Link 2000.

Who knows! Thank God it is working; I was not looking forward to buying 6 8D AGMs! Ouch!

09-09-2010, 01:36 AM

Yes, you can take the Link 2000 out of the equation temporarily by unplugging the modular phone type cable from the Inverter and turning the switch on the inverter to ON. To reset the Link 2000 and really solve the problem requires removing all power from the Link 2000 and that is not as straightforward as it seems as it is connected to both sets of batteries.

I did not spring for the AGM's and went with flooded cells. I think if I start saving now I may be able to save enough for AGMs by the time my wet cells fail.

This forum is giving me nightmares of head gaskets and that would make AGM's look cheap. Take care and good to hear your inverter is not misbehaving any longer. Russ

09-15-2010, 01:20 PM
As a final test, I decided to charge the batteries up to FLOAT (full charge) and then loaded them up. I disconnected shorepower to simulate dry camping: turned on 2 fans, refrigerator and ailse lights. These are the devices that run for about 9 hours during the night while we are sleeping. After the 9 hour test my batteries showed 12.40 and that is what they have been showing since new. Suffice it to say, my batteries are good and strong and will NOT need replacement.

I am certain that when I do need to replace them, I will use wet cells.

Thanks to everyone for all of the posts.

09-15-2010, 01:53 PM
Great news Tuga!

09-15-2010, 06:04 PM
Thanks to everyone for being here to help us all out! I'm leary of believing "experts" especially when they can cost us big bucks.